SHOP News & Articles Contact Impressum

Issues with CubeMars AK10-9 V2.0 motors: Cannot run/reset the motors

Dear Mybotshop,

We recently purchased many of the AK10-9 V2 motors for our robotics project and they have been working as expected. However, recently we have noticed some issues with ONLY some of the motors:(5 out of the 14 motors have this issue, the rest of the 9 work fine…)

  1. Cannot run motor mode (The noise that is produced when the motor starts is not heard anymore…)
  2. Cannot control motors to assigned positions/speeds/force (Basically nothing happens to the motors, they are just at the start point)
    We have tried this with the “CubeMarstool” software along with the R-Link device and also with our custom codes with an Arduino+STMboard+CAN transceiver devices. On both the test setups we are facing the same issue. However, it is interesting to note that both the “Calibration” and “Running the motor” works on the Debug mode.

We also tried the “System Reset” function on the “CubeMarsTool” but nothing happens and the motors still do not work.

Could you please recommend any solution for this?

I thank you in advance!

1 Like

@SubashHSA,

may you could check out this topic and post a screenshot if an what you are receiving? Testing Cubemars AK60-6 motor using arduino

Hi @SubashHSA ,

Did you manage to resolve this issue? I have been working with two AK70-10 motors and they have been working fine up until today. I am currently experiencing the same problem you are, where the motor works using:

  1. The CubeMarsTool software in debug mode.

However, it no longer responds to CAN commands to “enterMotorMode”, resulting in no noise produced by the motor. Which makes it impossible to control or do anything with them now.
Do you have any advice for resolving this problem?

Hi Nate,

may you could tell me your Version of the motors? Most probably the CAN Interface/ uC gets broken. This is happenening due to different potential in ground layer while the motor is trying the take the whole energy for the BLDC from the CAN - Which is destroying it.

If you are unable to control the motor via CAN anymore there are three things to do:

  1. Please check if the motor can be controlled via CubeMars Tool & UART anymore

If so, most probably the CAN interface is fault

  1. In that case you can measure if you are having a short circuit at CAN L & H
  2. If so, please try to remove the diodes very close by the CAN uC and measure the short circuit again.

If all of it doesn’t work, most probably you have to buy a new PCB.

Agreed with your suggestion. @MYBOTSHOP_Support

Hello,

I have now had the same problem with several of my motors, any other troubleshooting suggestions?

@jorgensao,

unfortunately not from our side. May you can share your setup and tell what is happening / or happened in the past?

Footer With Address And Phones