SHOP News & Articles Contact Impressum

Issues with CubeMars AK70-10 V2.0 and V2.1 motors: Cannot run/reset the motors

Dear Mybotshop,

I have purchased a total of 21 AK70-10s and one AK80-9 for robotics projects over the last months.

The motors have proven nominal when we do basic setup, but some of the motors develop a problem with the CAN bus. Similar to this issue: Issues with CubeMars AK10-9 V2.0 motors: Cannot run/reset the motors

Summary of the situation:

  1. We get the motors(7 AK70-10 V1.0 with driver board 2.0. and 15 AK70-10 V2.1 with driver board)

  2. Start using some of the motors for a robotic leg.

  3. Start noticing that some of the motors don’t respond to the CAN signal and won’t enter motor mode.

  4. Then, for 2-3 of the motors, they have been set to a lower current limit (testing current limit set to 5 out of 60) while doing initial testing, suddenly they are either reset to all values for the motor (motor id, baud rate, current limit) is set to 0 (Zero). Or they get reset to their default CAN id (1) and default current limit (60).

  5. Then, when using these motors, later on, the CAN stops working, and the motor cannot enter motormode. Neither with the R-link V2 nor with the Arduino with Seed studio or Sparkfun CAN bus shield. I tried with two different R-link V2 and one R-link V1, but none of them worked on these motors.

  6. Then we started noticing that some of the motors we had as backups(not unrapped from the plastic or removed from the box) also had a CAN problem shortly after starting to test them, even most of them without a load other than the motor itself or with using anything other than the R-link V2.

  7. For all the motors with the CAN problem, they are mechanically ok as they turn on using UART and can run the Calibration with the R-link debug mode. Most of the motors with Firmware 1.1 can use servomode also.

  8. I have confirmed that the setup, except for the motor, works by testing it on several other motors that do not have the CAN problem, and they turn on using both the R-link V2 and the Arduino setup.

I have attached images of the motor driver boards and the R-link setup together with screenshots of the R-link user interface.

I have changed the CAN wires on the R-link as they broke once on each R-link V2. I have also checked every wire and power cable to check that they were not the problem. I tried with both battery power and a PeackTeck laboratory power supply.

I also tried the factory reset in the Cubemars software.

I tried to run the fault command that shows up in debug mode to read the error message, it did nothing.

I tried to correlate if the lights (power =Blue, green=communication, red=error) correlated with the problem, about 60% of the motors had the red error light, but not all of the motors that were not functioning had the error light or the blue light for that matter even though they rotated the output shat when using the UART calibration function.





308279178_3307961726191461_5316812689215244381_n
308339975_779329450066926_4356651156087245851_n

So to summarise, 4 out of the 7 AK70-10 V1.1 has a problem with CAN communication, the same problem goes for at least 6 of the newer AK70-10 V2.1.

I would love to get some help with this. Looking forward to hearing from you soon!

Best regards
Jørgen

Dear @jorgensao,

thanks for issuing a post.

@Joy @Darrell could you please assist?

Hi @jorgensao
As I checked with your description, We supposed that the diodes of the CAN chip is broken on the board V2.0. Then you can not have the CAN communication.
If you can try to remove the diodes E1 and E2 on the back of the CAN chip, maybe you can get the CAN back to work.image

Hm, I can try that. Right now, I have two driver boards with working CAN communications – one has AK80-9 firmware, the other has AK70-10 firmware. Even if I can’t get the third board working, my preference is to get my two AK80-6 motors working, so if I can get the firmware I can “refresh” those two driver boards to AK80-6.

give me your email address. I will sent the hex file to you

Footer With Address And Phones