[Unitree Go1] Rviz model Issue / ROS Camera Activation

Hello guys, I’m using rviz for the first time. When I run roslaunch go1_viz view_robot.launch some parts of the model are not loading in and the camera views are not showing anything. I’m connected to the go1 and I’m also running roslaunch go1_bringup bringup.launch

Hi Kenneth,

Could explain which parts are not loading? It requires the driver to be running before hand for the parts to load in.

As for the camera it requires ROS multimachine with nodes running on each Nvidia. Instructions are in the latest version of README.md of the package.

Hope that answered your question.

S. O. Sohail

Screenshot from 2023-06-02 11-41-02
When connected to LAN the entire robots loads in just fine, but when I connect via the robot hotspot only the body and the head load in like in the image.
Screenshot from 2023-06-02 11-44-55

Are you running the driver on your PC?

Sorry, I’m not sure as to which driver you mean :grimacing:

The ROS high-level driver, the issue is that the joint states are not being published, and it’s most likely that the ROS driver is not running i.e. roslaunch go1_bringup bringup.launch.

Also, you have to make sure that the go1_base/launch/base.launch is configured with the WiFi settings. It should be written in the comments. Also, please make sure that you are on the latest version of the driver.

I have updated the repo but still getting this error:

. The bringup.launch file is working, tho I’m getting the error above. I’m controlling the robot via wifi by first launching the bringup.launch and then I run a walk node which I’ve made myself in a custom package which works. So the wifi settings should be good too I think.

Hi Kenneth,

Have you configured the go1_base packages launch file base.launch to the WiFi settings? Also, are you able to move the robot via teleop?

Hi Sohail,

I can move the robot via teleop, but I’ve not edited the wifi settings. The warning message is now gone except for this error:

But the robot model is now loading in correctly. I don’t know what fixed it tbh. However the camera panels are black and not showing the camera output. Any idea what that might be? It’s different from before. It’s not giving me any error message anymore of camera input not received, but the panels are now simply blacked out. I want to use the camera output in a custom GUI which I will create, because I’m dropping the VSLAM function for now.

Hi Kenneth,

Glad to hear its working, that error is because a joystick is not connected and can be safely ignored. If you do not plan to use a joystick, you can comment out the include file from the go1_control.

As for the camera, please follow the README.md in the main GitHub page of the GO1 that we have provided. It requires ROS multimachine to function. Basically, you would have to run the ROS driver in each of the Nvidia so that they can publish the image, then receive it in your main PC to then perform your operations.

Yes thx. I have done that, but the bringup.launch is now no longer working. It doesn’t give any error, but it doesn’t do anything when I run it. It just stays like this:
Screenshot from 2023-06-05 11-29-35

I think I did something wrong with the nvidea connection in bashrc.

Dear Kenneth,

You have to put each of the ROS URI etc. in each of the Nvidia boards respectively and not all in one .bashrc file.

The first one is correct however, for the other 3 they must be placed in the different boards. Moreover, you have to install ROS into each of them and clone our repository and run the GO1_camera drivers for each of them.

Ok I see. The Go1 is running ROS Melodic already, tho I’m using ROS Noetic on my laptop. Will that cause any issues you think?

Is there a way to safely update Go1s ROS Melodic to ROS Noetic? I don’t want to break anything. BTW thank y’all for the help so far, I really appreciate it.

Hi Kenneth,

ROS melodic and ROS noetic messages should be compatible with each other so that should not be an issue. ROS are usually tied to Ubuntu versions such as Melodic for Ubuntu 18, Noetic for Ubunto 20, etc. Although possible to use one in the other, most likely things will break if you try to install noetic in Ubuntu 18.

I would highly warn not to modify/update the GO1 Nvidia boards to a higher OS as it might break the existing system if you are not an “expert” in their system.

Going forward, I advise let them remain as Melodic, clone the Github repository, disable auto-start of the camera from the start menu, and launch the camera drivers.

So after I do this, will there be a topic I can subscribe to so I can show the camera views on a PyQt GUI screen for example?

Yes, once everything is setup using any interface such as pyqt, roswebtools, rviz, etc. you should be able to view the camera stream.

I installed the qre workspace on one of the nvideas. The one for the front camera. When I run it with bringup.launch I get this error again tho. I installed it only on one nano to test if it works.

Hi @Kenneth-vd-H,

Have you followed the GO1 camera multi-machine instructions on Github?

Yes. It seems to be on the pc side tho when adding this to .bashrc:
Screenshot from 2023-08-07 11-56-14