[Unitree Go1] Edu startup problems \ Network Issues


currently i am facing some Problems with our Unitree Go1 Edu Robot. After powering the robot, the robot is not Standing up anymore. I have already used your Troubleshooting Guide and found out, that there are no datas shown for BMS and Status.

I already have powered the robot with cable and battery pack, but the problem is the same.

As in the video is shown, i am able to bringup the robot into the standing position by remote controller, but the robot is very unstable.

hopefully you can help me.

Videos for explanation: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online..

Hi @alexhannover,

For the robot instability, it seems that you should calibrate the legs. As for the robot not standing up on startup, you can manually make it stand up via the SDK’s low-level controller. It seems the startup job may have got corrupted but I am not sure. Please tell, which GO1 hardware and firmware version does it have.

Thank you for your answer @Sohail,

The calibration havn’t solved my problem.
I can’t see, which hardware and firmware version i’m using (shown in the picture), but i know that i’ve installed the recommended versions for using the ROS-Packages.

Dear Alex,

It seems that you have one of the older models of the GO1, can you ssh into the GO1 main PC and run sudo ./bin/Legged_sport -v. It seems that your GO1 could be upgraded to of the newer versions but I have to confirm. There is a similar post from Nov '22 which you could also see in the forums here.

This is what i receive when i use:
pi@raspberrypi:~ $ sudo ./bin/Legged_sport -v

sudo: ./bin/Legged_sport: command not found

i guess i found my problem here, but i dont know how to fix it.
When i ssh into the raspberry pi and try to ping inside of the local network (192.168.123.XXX), i’m unable to reach the host.
It seems like there is a problem with the local network on the robot.

Hopefully that information is helpful,


Yes that definitely sound like the issue. For debugging try using:

nmap -sP 192.168.123.*
to see what networks are active, as well as

nmap -sP 192.168.12.*
and the normal 0 to check if the settings have changed
nmap -sP 192.168.0.*
You can then use the network info and compare with stock configuration. If anything is incorrect, you can use
sudo nmtui
to setup a static connection to correct it and delete the old one. For now, do this only 123 ips as the mobile one seems to be working fine for now!

Deleting the old connection and creating a new one did solved the problem.
At the first try after a reboot the new connection was disabled and i had to do the progress again. Now everything works fine. Remains to be seen if the problem occurs again.

Thank you for your help.

1 Like

Dear @Sohail,

it seems like i have modified the WiFi-Hotspot while fixing the other issue. When i was starting the robot i was able to connect my PC via Wifi, but after a few minutes (up to 5 minutes) my PC was entering the connection loop saying “Passwords or encryption keys are required […]”.
First i wanted to rename the WiFi-Hotspot and change the password to see whats happening, but now im unable to even see the network.

Hopefully you could help me again.

Best regards

Hi @alexhannover,

I would suggest first restarting the network manager via

sudo systemctl restart NetworkManager

If that does not help then, I would suggest reverting the changes you have done for the WiFi and restarting it otherwise trying to reset the entire Access Point would be messy.

Also, to change the WiFi settings:

sudo nano /etc/hostapd/hostapd.conf

@Sohail, i tried your advice and went back to the old settings. Now i can connect to the network again, but the same problems occurs: After a few minutes the connection is lost and i have to restart the robot.

Does restarting the network bring back the network? You can check via ifconfig. An alternative you can try is to disable the native GO1’s accespoint (AP) and creating a new AP network.

Hi @alexhannover @Sohail,
I am facing exactly same issue with Unitree go1 edu we have. After around 4 weeks of normal operation of the robot we see the entire network on the robot is wiped out. Can you please give more details how did you re-create this network on the robot ? nmtui is a graphical interface so it will be hard to establish a new connection through a terminal ? Am I right ? Would really appreciate if you provide me a guidance.

Hi @alexhannover,

sudo nmtui

works on the terminal. What do you mean the entire network is gone?

Hi @Sohail,

nmtui its not installed on go1. There is also no connection to the internet.
By network gone I mean i can’t ping anything from .123


You would then have to connect with HDMI and keyboard. First I would advise enabling the internet by changing the connection to DHCP; install all packages that you require and then changing the configuration back to the board’s respective static IP which you can get from the docs.


Also, I would redirect you to the GO1 slack community. You can find possibly a copy of the board with the default network configuration.

@Sohail I would like to participate in the GO1 slack community. Would that be possible?

Yes, of course, you can simply join the slack channel.

1 Like

Hi. It says: Don’t have an email address from one of those domains?
Contact the workspace administrator at TheDogPound - Animal control for stray robot dogs for an invitation.

Can you please provide me this invitation?