SHOP News & Articles Contact Impressum

Unable to connect Nvidia PC of Unitree A1

Hi, I have encountered the same issue as it’s described in the Problem with NVidia board of A1 robot - #17 by AlaricLcrs.

I have tried connecting with HDMI or via ssh from the onboard Raspberry PI. But it could not connect to the Nvidia-PC. Furthermore, there is no wifi broadcasted by the Robot. Namely, I can’t find the wifi called UnitreeRoboticsA1-xxx.

I wondering how this could be fixed. Much appreciate.

Hi @bbh
Can you share the ip address of the board to which you are trying to get access?
Also for Wifi have you changed any network configuration?

I’m trying to get access to 192 .168.123.12 (which is the nvidia’s on-board PC). I never changed any network configuration since I couldn’t even connect to it via wifi. Its wifi hotspot is not activated at all.

Have you changed your own connection to 192.168.123.** range?

I couldn’t even connect the Nvidia-pc when I was using the onboard raspberry PC.

When I connect the hdmi to the nvidia-pc, it also doesn’t show up anything. I tried already conncet the cable before the robot started or after the robot started. But neither of them works.

No, what I mean is that your Host-PC, what is the IP address, not of the Nvidia-PC/A1. Maybe send the output of the command $ ifconfig of your PC?

here is the output of ifconfig:
(base) hcg@localhost:~$ ifconfig
docker0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 172.17.0.1 netmask 255.255.0.0 broadcast 172.17.255.255
ether 02:42:90:fb:16:cb txqueuelen 0 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

enx9cebe8373871: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.123.51 netmask 255.255.255.0 broadcast 192.168.123.255
inet6 fe80::bd03:940a:339b:57ee prefixlen 64 scopeid 0x20
ether 9c:eb:e8:37:38:71 txqueuelen 1000 (Ethernet)
RX packets 2 bytes 166 (166.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 85 bytes 9034 (9.0 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 960 bytes 78331 (78.3 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 960 bytes 78331 (78.3 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Does your A1 have an ouster mounted on?

Yes. I have it and I even could ping to the ouster lidar when I have ssh into the Raspberry Pi.

Ok that is good it means that the Nvidia-board is starting up. It means that the ip address of Nvidia might be a different one. Please try running this command and posting its output. Make sure you are connected to the A1 with the Ethernet.

sudo tcpdump arp

unfortunately, I can only find 192.168.123.10, 192.168.123.2, 192.168.123.51 (myself), 192.168.123.161. So it still could be the case where the nvidia-board isn’t started.

What is at 192.168.123.10? Try ssh’ing into it.

Also I would recommend plugging in the HDMI and power cycling the robot, and if you can attach a usb keyboard to the Nvidia board in case that the display is going to sleep.

@bbh could you please post a picture of how the A1 is wired at the moment? So we can see in which port you have add your Ethernet Cable, HDMI Cable etc?

Thanks in advance!

Have tried connecting to 192.168.123.10 and it returns connection refused. I think it’s the controller board (See https://www.trossenrobotics.com/Shared/XSeries/A1SoftwareGuidev2.0-en.pdf)


Here is our setup when connecting with ethernet cable. The HDMI port at the same side also works well. But when we try using the front port, both ethernet and hdmi give nothing.

We have tried this too and nothing shows up for the nvidia board.

Dear @bbh,

thanks for your message and posting! Just to letting you know, the from PC is the NVIDIA.

@Sohail @Tahir Do you have an idea how to figure th problem? May arranging a TeamViewer Session to check the IP configurations of the Master PC?

@bbh , one more question do you see the WiFi Hotspot of A1?

Footer With Address And Phones