Software update on Unitree A1

Dear community

I have recieved and installed a software update (qre_a1-3.3.1). Although the installation and the catkin build worked fine, there seem to be some issues with the IP adress configuration. I tried to launch the a1_base node through the base.launch file but ended up with the following error:

When analysing the issue, i found that the IP address can be configured in the base.launch file, so I tried every combination in there, but I got the same error every time.

Additional Info:

  • Our Unitree A1 has the two computer setup - one Raspberry Pi ( and one Nvdia Tx board ( In contrast to most software and user manuals, the IP addresses are switched up. Since we are running ROS on the Nvidia board, I believe this could be the place to start troubleshooting.
  • We are trying to run the high-level controller.
  • Since there are no dependencies listed, I have placed the package in a empty catkin workspace. This seem suspicious to me, since the old version had some dependencies on the unitree_legged_sdk and lcm-server.

Does somebody know what the IP address in the base.launch file corresponds to and what the correct one would be in my case?
Are there any additional dependencies not listed in the package description?

Thanks in advance

Dear @quadrupedUser,

Can you confirm if the v3.2.0 is working?


Thanks for your response. Yes the Version 3.2 does work, but it seems to me that the structure of the whole package is significantly different.

There is no a1_base to replace in my current version.


1 Like

That is correct. In 3.3.1 everything has changed, infact to operate it using the high-level ROS, the A1 has to be put in sports mode. Also currently, the A1 joint description has not been verified with 3.3.1, which we are working on, however, it is not a high priority due to which no time line can be given for it.

1 Like

Ok, i have double checked that the robot is in sports mode, but the error remains. May I ask what the meaning of the IP address in the base.launch file is for, and how I would go on to find the correct one?

Another question that has come up during the analysis of the updated software is: What are the advantages of the version 3.3.1 in comparison to version 3.2?

The main advantages are core features of high-level commands such as the provision of odom based on the gait as well as new dance options. In terms of low-level there is no advantage.

1 Like

Also in built odometry calculation. One thing to check is whether your A1’s firmware has been updated, its sport mode version should be >= 1.19. You can check it via the mobile app or via this previous forum.

1 Like

Thanks for mentioning that previous forum post, I am actually continuing this project startet by Tenzin who wrote this post. It looks like they had the same issue, which still hasn’t been fixed. The firmware Version should be >= 1.19.

In the mentioned forum post an updated version 3.3.4, that should fix this issue is mentioned. Do you know if this version already exists and how I could get the updated version?

The working version is here, the issue of joint state publisher is remaining though. The basic high-level and low-level commands should be working though.

Thanks, I will try that version. The link however doesn’t seem to work for me, I’m only getting a 404-Page not found error. Could it be that the repo is private?

Yes, please either send a private message of your github username/id so that you can be added to the repo.

1 Like

Thanks for inviting me to the github repo. As far as I can tell, the code on Github is identical to the one I’ve previously installed. And the error still remains.

I suspect that there is a problem with the IP address of the base.launch file. Assuming the issue lies there, how can I determine the correct one?

Could you please report back the hardware firmware version of your A1?

Im no sure what is meant by hardware firmware version. Do you mean the version that can be accessed via

cd /home/unitree/Unitree/keep_program_alive 
./bin/A1_sport_1 -v

If not, could you tell me how to find the according hardware firmware version?

yes this one. Also for the firmware version it shows via the A1 app

I have double checked the version on the RPi which is indeed 1.19:

Since there is no Unitree app in the app store, i downloaded the beta version with test-flight to check the firmware version there, but it was not able to connect with the robot. But we are not interested in using the app, so this proposes no problem to us.

Could you switch the base ip to 161 and test. For ours, the .10 seems to works but perhaps its different for you. Also please repost the new error.