[Unitree Go2] Problem with the Lidar 4D LiDAR L1

Good day, Gentlemen,

I have encountered what appears to be a hardware issue with my Unitree Go2 Edu robot dog. The 4D LiDAR L1 is inconsistently publishing data to /utlidar/cloud. For a few seconds, I receive a point cloud, then there is silence for a few seconds, and then the data starts coming in again. This pattern repeats throughout the robot’s operation.

Visualization in rviz2 confirmed my suspicions about the instability of data publishing to the topic.

Unfortunately, I only noticed the problem recently when I tried to implement SLAM on my own based on readings from the 4D LiDAR L1. I checked the official “Unitree Go” application and saw that the environment rendering works.

I then went to “Device” → “Data” → “Unitree Perception LiDAR,” where I noticed that the “Packet Loss Rate” in the “PointCloud Data Status” fluctuates between 92 and 98%.

Mechanical notes:

  • The LiDAR spins quite rapidly;
  • The green light on the LiDAR also works for a few seconds and then goes out, only to light up again briefly;
  • There is an additional hum from the LiDAR, which, like the green light, periodically turns on and off (but NOT in sync with the light);
  • I could not establish a direct correlation between data publication and either the green light or the humming;
  • Nothing is obstructing the LiDAR. The rotation is unhindered.

I would appreciate your suggestions. Could this be a warranty case?

Dear @MusubaPy,

Have you tried connecting an HDMI cable to the Go2 directly and viewing Rviz2 in it directly?

If you are viewing it over LAN and/or WiFi. Then most of the data would be cut off. If when viewing the lidar directly through the robot and data is cutting off then it could be a warranty case.

It would also be worth trying the qre_go2 repository that you can gain access to via support@mybotshop.de for direct usage with the slam_toolbox

Thank you for your quick response @Sohail!

Yes, I am performing all manipulations directly on the robot, connected via HDMI. I did this to minimize the possibility of communication issues between computers.

I already have access to the qre_go2 GitHub repository. However, I fear the problem lies within the LiDAR itself, as the data is being truncated.

Can I open up the robot for a visual inspection without voiding the warranty? This behavior strongly resembles an unstable connection between the board and the LiDAR.

Best regards

If this is via HDMI please contact support@mybotshop.de. This definitely seems that there is something wrong with the Go2 Lidar.

@Azib Could you please confirm if warranty is voided?

Dear @MusubaPy

I hope that you are doing well.

I would suggest not opening the Lidar as the wires are quite delicate. Please let us know if you have bought the robot from us. If so please send us your purchase ID at Support@mybotshop.de and we can arrange the shipping for you.