[Unitree Go1] Obstacle Avoidance Mode not working

we received a Go1 from quadruped.de a few weeks ago. We tried to use the Obstacle Avoidance Mode with the Controller as follows:

From the docs

GO1 Basic Operations

In advanced mode (Triggered by pressing START two times rapidly):

  • Obstacle avoidance: Y (On)
  • Obstacle avoidance: X (Off)

We expected Go1 to react like in this video

However, Go1 starts walking backwards immediately when Y is hit on the controller until either it walks into something or we cancel the Obstacle Avoidance Mode.
This happens no matter how much space is around Go1 (we tried in an empty space of 4mx4m in front of Go1).

During a call with quadruped a few weeks ago, the key account manager mentioned, that the Obstacle Avoidance Mode sometimes is deactivated in shipments from Unitree and needs to be activated first.
Could this be the issue here?

Dear @anna,

Could you please tell us the GO1 model you are using (edu, pro, air)?

Also, just to make sure, have you tried the obstacle avoidance mode in a clear area, as in the newer versions of GO1, the ultrasonic mode has been removed and is completely vision based.

Also, please try approaching the GO1 from the side to see if it moves to the side.

Dear @Sohail,

thank you for the reply :slight_smile: We are using a GO1 edu.

Fortunately the error is not present any more. We noticed last week that one of the computers did not send MQTT messages because it was completely missing the paho.mqtt library. We fixed this by installing the library. Apparently this also fixed the Obstacle Avoidance mode.

Now Go1 behaves as expected :slight_smile:

1 Like