[Unitree Go1] failed raspberry boot, no sd card found

Hi everybody,
we have the go1 edu v1.6 and it’s raspberry compute module won’t boot up anymore. How do I proceed?

Error at boot up

Is there a SD-Card inside at all? Or is there a eMMC-Module?

Dear @emg,

Please provide the following information

OS: (e.g. Ubuntu 20.04)
ROS Distro: (if applicable)
Built from source or installed:
Package/SDK version: (if from the repository, give version)
Real hardware or simulation:

Expected behavior

A clear and concise description of what you expected to happen.

Actual behavior

A clear and concise description of what you encountered.

To Reproduce

Provide the steps to reproduce:

  • run something
  • launch something else
  • see the error
  • Other notes

On a side note we can provide the go1_pi image clone, however, we are unsure whether it is compatible with your go1.

Dear @Sohail,

thank you for your response.

OS: I guess it’s 18.04 (at least the working Nano-1 and Nano-2 are running Ubuntu 18.04)
ROS Distro: don’t know
Original Installation as to delivery. No changes made.
Real hardware GO1-EDU: GO296961A V1.6 A2203100001

Expected Behavior:
Bootup of Raspberry 4 compute module (2GB)

Actual behavior:
Failed to open device ‘sdcard’ (SD: card not detected),
Error at boot up
second boot order ‘Network’ is tried (TFTP connection) and is failing of course

To Reproduce:
System is not booting up each time

I especially would like to know if there is a possibility to check/renew the SD-Card or eMMC or the Raspberry 4 Module.

Best regards

I am not exactly sure what happened, but I can provide you with the default GO1-Pi img to reflash it. However, it might be the case the sd card has moved or something in the hardware is incorrect. Also, it is recommended to not reflash and exhaust all other options before.

@Azib Can you please verify?

Dear @emg ,

Based on the image presented, it appears that the SD card may be experiencing malfunctions, or the connectors might not be securely connected to the Raspberry Pi. I recommend checking the card’s connectivity by unplugging and then re-plugging it into the Raspberry Pi. If the issue persists and the system does not boot up, please inform us so that we can contact the manufacturer to address this problem before attempting to flash the card.

Hi all,
I opened the robot to check the sdcard. Some screws (head of the robot) were tightened so hard, that I couldn’t loose them. Even one of my screwing tools was broken. Other screws I couldn’t get out because they got stripped. A mess, indeed.

Finally I could open the robot and get out and check the sdcard. It worked (!) and I did a dd backup. After re-inserting the sdcard the RPI module booted up again. :man_shrugging:

OS obviously is Debian 10 Buster (/etc/issue). Another problem I have (already before the sdcard didn’t work) is the AccessPoint (Unitree_Go296961A) functionality. It was and still is not stable, most of the time it’s not working. It seems, that the problem depends on dhcpcd interaction with hostapd/dnsmasq.

Maybe you can provide the available Raspberry Image so that I can look into it if the configuration differs from mine. Thank you.

Best Regards

Dear Peter,

This is the available GO1 image that we have. However, since we are unsure of your setup, we cannot recommend testing it. At your own risk you can try (it should probably work!).

S. O. Sohail