[Unitree A1] Connecting to internet

Hello dear community,

I would like to connect the Jetson Xavier NX to the internet to install some packages.
Connecting the ethernet to the lan port does not work and neither using a usb to ethernet converter.

What steps are neccessary to connect the NX to the internet?


Dear @Martin, You can connect in one of three ways.

  1. By using a WiFi dongle.
  2. By sharing the internet through your LAN cable example.
  3. By disabling the ethernet bridge in the Nvidia NX installing all the required packages/software and then re-enabling the internet.

Dear @Sohail,

could you elaborate how to disable the ethernet bridge in the Nvidia NX?

Kind regards

A1 Internet via Ethernet (Experimental)

This procedure requires the PC to be able to connect to the internet from at least 2 sources.


  • Ethernet cable
  • Desktop\Laptop with access to wifi or multiple internet ports.

Main PC

  1. Create a new wired connection from the main PC which can be found in the the top right-hand corner in networks.

  2. Open a terminal and type the command

sudo nm-connection-editor
  1. Select and edit the newly created ethernet connection and in IPV4, change the IP address to shared-to-other-computers

  2. Write a static IP address with netmask as 24.

    • Ensure the Ethernet tab has the correct device that is connected to the A1.

Nvidia PC

  1. Connect to the display of the Nvidia pc (the front ports of A1), and enter the following command in ther terminal
sudo gedit /etc/network/interfaces
  1. Comment everything out by putting # infront of all the lines in the open document and save the file.

  2. Next enter the command:

sudo systemctl restart NetworkManager.service
  1. Next edit the connection via the networks located on the top right, and change the ethernet connection to manual.

  2. Give the IP and address as 24 and change the DNS to as

  3. Goto

sudo gedit /etc/resolv.conf
  • and add nameserver
  1. Incase its not working check in software and updates that the version is not US.

  2. Once completed with the internet, you may un-comment the lines in sudo gedit /etc/network/interfaces, and restart the A1 nvidia pc.

Please keep a backup of all files and be careful, it is recommended to tperhaps use a WiFi dongle to avoid this type of configuration.

1 Like

Alright, thank you very much for the description and you already answered my second question about the reconfiguration!

Kind regards

1 Like

Dear @Sohail,

I tried connecting the NX system via a USB-to-LAN converter without success.
Altough I can reach the systems via their designated IPs through the converter, I cannot reach any site on the www on the nx system.

On my laptop (windows) I went to Control Panel > Network & Sharing > Network Connections > right-click on the WiFi connection > Properties and enable sharing the connection to other computers.

After enabling sharing I set the IP of the LAN connection and following the steps from the link you provided (2.) but unfortunately there is no internet connection established.

Do you have any idea?

Kind regards

Hi @Martin,

You have to set the IP when configuring the shared network connection. Once done and everything on the NX system is commented in /etc/network/interfaces, do ifconfig and make sure that you have a static connection setup with .12. Restart the Nvidia NX, add the name server to resolv.conf and ping google.com to check if it has started.

Hopefully, this should work.

S. O. Sohail

1 Like

Maybe this is totally random and a waste of time, but we were also not able to connect our A1 to the internet because our robot was configured to a different timezone (somewhere around 2018).
If your robot faces the same issue, you could maybe check if setting the timezone manually helps.