[Turtlebot4 Lite] Issue concerning /stereo/depth topic

In my Turtlebot4 Lite, I have an issue concerning the /stereo/depth topic.
When I launch it, it doesn’t return any data:

While the image and scan topics are working well.
What should I do ?

Dear Mr. Raoui,

Please try changing the DDS protocol in the same terminal from which you are running the turtlebot4 depth cameras driver

sudo apt install ros-foxy-rmw-cyclonedds-cpp
export RMW_IMPLEMENTATION=rmw_cyclonedds_cpp
echo "net.core.rmem_max=8388608\nnet.core.rmem_default=8388608\n" | sudo tee /etc/sysctl.d/60-cyclonedds.conf

Dear Mr Sohail,
I made changes to the DDS protocol, but the problem persists.

Please also run the same commands on your computer from which you wish to view the depth camera in the terminal.

export RMW_IMPLEMENTATION=rmw_cyclonedds_cpp
echo "net.core.rmem_max=8388608\nnet.core.rmem_default=8388608\n" | sudo tee /etc/sysctl.d/60-cyclonedds.conf

The echo net.core command should only be run once in both the TB4 and your PC.

I have the humble ROS2, which by default is configured to use rmw_fastrtps_cpp.

When running tee /etc/sysctl.d/60-cyclonedds.conf
I get

`[ERROR] [1697636563.721690849] [rcl]: Error getting RMW implementation identifier / RMW implementation not installed (expected identifier of ‘rmw_cyclonedds_cpp’), with error message ‘failed to load shared library ‘librmw_cyclonedds_cpp.so’ due to dlopen error: librmw_cyclonedds_cpp.so: cannot open shared object file: No such file or directory, at ./src/shared_library.c:99, at ./src/functions.cpp:65’, exiting with 1., at ./src/rcl/rmw_implementation_identifier_check.c:139


please install

sudo apt install ros-humble-rmw-cyclonedds-cpp

I changed the protocol but the issue persists

Is the point cloud visible? It seems that the driver parameter may be disable and you simply have to change the parameter.

I think no:

That is laser scan and it is not coming from the stereo camera, it should be coming from the LiDar. Please check the TB4 launch files to see if the depth stereo camera is being launched.

Ok. Can you send me the path of the launch files ?

The command should be:

ros2 launch turtlebot4_bringup oakd.launch.py

Additionally, dependencies should be installed on your PC (as mentioned) via:

sudo apt install ros-humble-depthai-ros

Just in case make sure that the depth camera is attached to the robot on the USB 3.0 port, it should be there by default.

Once you run the depth camera, check via ros2 topic echo /<depth_topic> to see if the data is coming or if there is any error in the launch file. In case there is an error please post it here.

I launched oak.launch.py
I get this issue:


ros2 launch turtlebot4_bringup oakd.launch.py namespace:=tb4

I tried, it doesn’t work:

There is one for oak_lite, please try that.

ros2 launch turtlebot4_bringup oakd_lite.launch.py namespace:=tb4

You can do ros2 launch turtlebot4_bringup and then press on the keyboard to show the available launch files.

I didn’t find oakd_lite.launch.py


It seems that they removed it in the latest version.

Please launch this in the turtlebot4 PC.

Issue resolved by changing the launch param from oakd_pro to oakd_lite as well as switching to the oakd_example.launch.py.