[Turtlebot4] 3d camera malfunction Turtlebot pro

Hi dears,

Turtlebots are great and we are happy with the purchase, we would have only one problem, the 3D camera in one of the three models is not detected by the control system.
We tried connecting it directly to a pc with the management software provided by the camera manufacturer (OAK-D) and again it is not recognized.
In contrast, the same test done with the camera of another Turtlebot was successful and the camera works.
The remaining functionality of the robot seems to be fine.

Could you give us any indication of what the problem is and how to solve it ?

Looking forward to your cordial reply I wish you a good day.

Dear @alfredogts,

Could you please mention the Turtlebot version that you have i.e. turtlebot4 or turtlebot4 lite. The OAK-D is known to have issues sometimes. Mostly this can be solved by reflashing the pi with a fresh Tb4’s image. Otherwise, another option is to post the errors on when you launch the OAK-D camera.

S.O. Sohail

Dear @Sohail,

The model is Turtlebot 4 TB4 Pro, we bought 3 of them and only one has this problem.
The solution you proposed has already been tried but did not give results unfortunately.

The error is :
[1944301031594D1300] [1.4] [1.355] [ColorCamera(0)] [error] Camera not detected on socket: 0

Could you confirm whether the connection from the camera is being detected by the pi or not. You can do this by typing the command

lsusb -v

and seeing if oakd shows up, if the oakd itself does not show up then you can switch to another cable. Form there onwards we can see other debugging steps. Additionally, could ou try plugging the oakd into one of the other turtlebots and see if it works there. The camera itself might be faulty in this case.

the camera seems to be present among the various devices connected to the Raspberry but:

  • when it is not working there is no output. On no Raspberry.
  • working cameras, they are both on their respective Raspberrys and on the Raspberry on which the non-working camera does not work. So it can be ruled out that it is a Raspberry problem.

Also, both the working cameras and the one that does not work have been tested on Windows. From the screenshots you can also see the error and the GUI that you have when the non-working camera is connected.

Dear @alfredogts ,

Regarding the problem you’re experiencing with the camera, there are two potential reasons for its malfunction:

  1. The camera cable might be faulty. You can verify this by swapping the cable with one from a working camera.
  2. The camera itself may be defective.

Please inform us of the specific issue so that we can promptly escalate your concerns to the relevant department for immediate attention.

Dear @Azib ,

The power cable worked with the other cameras.
Unfortunately, the malfunction concerns the camera.

I await your guidance and support on this.

Kind regards.