SHOP News & Articles Contact Impressum

Turtlebot Waffle + Open Manipulator

Hi mybotshop,

I have setup a combination of the turtlebot with the open manipulator arm. Currently I have problems with one of the motors (joint: 11) when uploading the firmware to the OpenCR board: all other motors get torque and move towards the init position, but the motor with ID 11 does not have torque, and does not move.

I am able to read the sensor information of the motor in ROS, but when trying to send a movement command, the motor does not move. I suspect that the problem is in the om_with_tb3.opencr firmware file.

I did try to swap motors, but the error persists. When controlling the open manipulator arm via usb_to_dxl, the motor with ID 11 does move, so that is why my suspicion is in the opencr firmware.

Do you have any suggestions on what this problem can be? If you need more information about my setup, please feel free to ask.

I hope you followed the instructions here.

Well that could be a problem with motor id but as you said the manipulator works fine when controlling alone then most probably its the problem with firmware.

I have two suggestions for you:

  1. Use not the latest version of OpenCR binaries. I have used these binaries a few months ago and everything worked very fine. If you see on their GitHub the latest version is updated a few weeks ago and the the other ones a few years ago. They are stable as per my experience.

  2. I have seen you have opened an issue. If you can look into there latest commits may be have a look and fix by sorting out the problem.

Hi,

Thanks for your response. I did follow these instructions. I also tried different versions of the firmware from the github of OpenCR binaries. It is strange that it should work for you, but it doesnt for me.

I will look into the github commits , maybe I can find the issue there.

Hi Tahir,

The problem still persist. Can you give me some more information on your setup? How are the Dynamixels set-up for example?

kind regards,
Vincent

Hi Vincent,

I just saw a recent commit in the GitHub repo for binaries that was one hour ago. There commit is named tb3_omx fw hotfix may be this fix your problem with Open Manipulator.

Also The Korean office of Robotis if closed due to Chinese New Year till next Monday so may be wait until that time.

Good Morning Vinsento,

thanks for your message.

Do you have a U2D2 or a second OpenCR Board? If not are you able to use the OpenCR which is integrated in the TB3 and run the Monitor sketch?

Please post the output here.

P.S. Please don’t forget to add the DYNAMIXEL and power :slight_smile:

Hi, Thank you for your response. I only have the OpenCR board available in the turtlebot. The output I have here (not sure what you want to see):

Set begin before scan or ping
help
begin (BAUD)
scan (RANGE)
ping (ID)
control_table (ID)
id (ID) (NEW_ID)
baud (ID) (NEW_BAUD)
torque_on (ID)
torque_off (ID)
joint (ID) (GOAL_POSITION)
wheel (ID) (GOAL_VELOCITY)
write (ID) (ADDRESS_NAME) (DATA)
read (ID) (ADDRESS_NAME)
sync_write_handler (Ref_ID) (ADDRESS_NAME)
sync_write (ID_1) (ID_2) (HANDLER_INDEX) (PARAM_1) (PARAM_2)
sync_read_handler (Ref_ID) (ADDRESS_NAME)
sync_read (ID_1) (ID_2) (HANDLER_INDEX)
bulk_write_handler
bulk_write_param (ID) (ADDRESS_NAME) (PARAM)
bulk_write
bulk_read_handler
bulk_read_param (ID) (ADDRESS_NAME)
bulk_read
reboot (ID)
reset (ID)
end

Press Enter Key
[CMD] : begin
Succeed to init : 57600
[CMD] : begin 1000000
Succeed to init : 1000000
[CMD] : scan
Find 7 Dynamixels
id : 1 model name : XM430-W210
id : 2 model name : XM430-W210
id : 11 model name : XL430-W250
id : 12 model name : XM430-W350
id : 13 model name : XM430-W350
id : 14 model name : XL430-W250
id : 15 model name : XL430-W250

Hi Tahir, I noticed this one too, but it did not fix it for me unfortunately…

Dear Vinsento,

excuse me for the late reply. Do you have a U2D2 available?

Hi, no unfortunately not, but I was already thinking about buying one. Could this help in the debugging capabilities? I will order one today.

Hi, yes that could help because in that case we could run DYNAMIXEL Wizard and check the paramters and firmware. If the DYNAMIXEL is having any issues it will be displayed in the software.

https://emanual.robotis.com/docs/en/software/dynamixel/dynamixel_wizard2/

Hi, currently I run the DYNAMIXEL Wizard through the Opencr board with the usb_to_dxl firmware. How is this different when running this with the U2D2, can you elaborate?

Kind regards.

Hi Vinsento, its exactly the same! I’m sorry for that didn’t thought about this option - My fault :see_no_evil:

Could you please run a test and send us the report?

One more question please, when you’ve purchased the Kits?

Good morning,

This is the results I obtain with the dynamixel wizard.

Everything looks fine to me here…

I bought the turtlebot package about a year ago, and the two more powerfull motors (XM430-W350) more recently (December 2020).

@Vinsento
Oh, now I see the issue here.
I thought you have the official manipulator in turtlebot3 issue thread.
The official OpenMANIPULATOR-X uses XM430 series and this model supports Current control mode.
Since the gripper (ID #15) requires current based position control mode, XL430 won’t be able to support the mode and therefore, the manipulator won’t get initialized properly.
Replacing XL430 to XM430 for ID 15 will resolve the problem.
Thanks!

Footer With Address And Phones