[TurtleBot 4] Faulty TurtleBot -Dead on arrival

Unfortunately we are experiencing problems with one of the robots we received before Christmas.
See delivery details in the conversation below.

According to the user:
“We are facing an issue with one of the Turtle-Bot robots we received. Unfortunately, it has been experiencing a permanent failure since we unpacked it. Despite being able to charge its battery, the robot is unable to boot successfully. Specifically, the lidar is non-functional, there is no display on the screen, and the LEDs fail to turn green, in contrast to the other robot.

We’ve attempted various troubleshooting steps without success. We would need more guidance from the supplier on potential solutions or further diagnostics we can perform to resolve this issue.”

Who should we contact for technical assistance in this matter?

The problems the user sees are visualized and explained in this video clip:
(VID_20240124_093001.mp4 - Google Drive)


Dear @larsn ,

The issue you’re encountering could be because the robot is in storage mode. I strongly recommend watching the video linked below, which will guide you through turning on the robot and switching between modes.


The video link that you have provided doesn’t seem to work. I have been trying to follow the following tutorial that have been mentioned in the manual that came with the robot.

Turtlebot unboxing
Also I am following this as mentioned in the manual.

I would request you to please give us prompt responses so that we can get the robots working, Please provide the correct working link of the video.

one of the robots that we have received is completely dead and doesn’t respond at all. the other robot doesn’t have its wifi visible. I have tried ssh into the raspberry pi and get the wifi configured but still it is not working.

I would request detailed response with proper steps highlighted.


Also, why is it that the manual link that you are providing is different from what came with the robot?

Dear @Himanshu ,

We offer a video link as it is more convenient for our customers to comprehend the functionality of the robot through video rather than reading the manual.
Below is the official video link from Clearpath, explaining the operation of Turtlebot 4.

We can also setup a meeting to solve the current problem that you are facing.


I saw your video, uploaded the firmware, and I tried following the steps. However, it doesn’t help at all. Firstly, the video has steps for Ros Galactic and Ubuntu 20.04 and for the lite version of turtlebot.

We have purchased the standard version of turtlebot which has better hardware and a different structure. You need to give us the instructions in a proper way. It is really bad to see that the manual that comes manual with the robot has completely different instructions compared to what you have shared in this video. This is not at all helpful.

I would like to have a call with your support team and would like to get this issue fixed with them. Also, I would want that to be arranged as soon as possible. This is creating a lot of problems as the students are not able to work on the robot.

I am looking forward to hearing from you.


The lidar and the screen are still unresponsive even after the firmware update and moreover, the video that you have shared has a robot that doesn’t even have them. I don’t understand why are you sharing wrong support instructions.

Please check the video that we shared with you earlier, the situation is the same still.

In your video, you mentioned Bluetooth mode, which is visible through a blue light. How do I even see it with the structure on top of it and How do I even put it on with this structure? I have tried rotating it but still, I cant see or access any Bluetooth buttons that you have mentioned.

The provided robot is from Clearpath that builds upon another third-party vendor i.e. iRobot in this case. We agree that there should be clearer instructions on the manual and will request Clearpath to add it to their documentation.

Please email us at support@mybotshop.de with times in which you are available for a meeting.

The lidar and the screen are still unresponsive even after the firmware update

This may be a hardware fault in the robot, and/or it has not been removed from storage mode. To remove the robot from storage mode, please start the Turtlebot4 when it is in the docking station. It should activate it.

the video that you have shared has a robot that doesn’t even have them. I don’t understand why are you sharing wrong support instructions.

As mentioned previously, the Turtlebot4 is built upon the iRobot with multiple add ons e.g. Lidar etc. Also the link to documentation is provided in the TB4 manual website.

For now, I will recommend contacting support@mybotshop.de mentioning that there is a hardware issue and we will contact you again with several options most probably with free return shipment so that we can diagnose it, verify the issue, and resolve it.


Thank you for the response. we have got the lidar working for on of the robots. However, the other robot is still dead. We would like to have a call with you guys on Friday at 16.

Please let us know if this works for you. I will be there along with the students to attend the call and have the issues with the robot fixed.

I am looking forward to hearing from you.