SHOP News & Articles Contact Impressum

RP LiDAR A1M8 + Cube Orange&Arducopter connection issues [solved]

Dear collegues,

→ see solution at the end!

I have some connection issues with a RP LiDAR A1M8. Maybe one of you could give some advice? Thank you in advance and for reading this!
I like to use the LiDAR on a quadcopter using a Cube Orange and Arducopter. After reading the Cube’s and Arducopters manual I came to the following setup:

Cube Orange on Arducopter V. 4.0.7
RP LiDar A1M8 Firmware V.

The LiDAR is connected to a BEC(5V/3A) and the cube’s GPS1 (UART3) port:

Pin1,2,4 (Vmoto,Motoctl, V5.0) to the BEC’s 5V Output.
Pin3 (GND of motor) to the BEC’s GND.
Pin5 (TX) to the Cube’s RX (Pin3, GPS1 port)
Pin6 (RX) to the Cube’s TX (Pin2, GPS1 port)
Pin7 (GND) to the Cube’s GND (Pin8, GPS1 port)

Parameters of Arducopter are set like here: RPLidar A2 360 degree lidar — Copter documentation

====>>>>> SOLUTION: <<<<<====

In the cube’s manual there’s a wrong Pin - description (numbers!), see attachement. After I changed Pin2 and Pin3 the LiDar worked!

Footer With Address And Phones