Protoneer Pi CNC Hat, no connection

Bought a Protoneer Raspberry Pi CNC Hat and installed the official image on a Pi 3 b+.
In bCNC there is no connection and when I run the update script it shows not in sync: resp=0x00
See attached screenshots.

Dear Pless,

thanks for the screenshots. Could you post a picture of the CNC Hat as well? Is there any LED flashing?

Yes TX is flashing.

Thanks for the second picture as well. In my opinion if the TX LED is flashing the Board is waiting for a communication and the bootloader is still on the Board.

Could you please run the following command and post the output?

dmesg | grep tty

We’ve informed the manufacturer, who will post his opinion as well.

So any news on this?

Dear Pless,

I’m very sorry for my late reply.

I could offer you two options:

  1. We will ship a new CNC Board today and after receiving it, you will ship back the old one
  2. You will send us your Board and we can check if everything is working properly

At the moment I think the issue is caused by wrong configuration. Maybe you would like to flash a complete new Image on the SD-Card and check it again?

Ok option 1 sounds good to me.
I have tried a different Pi and also standard raspian, still no change. So a new board would be nice :blush:

Sure, we will ship a new Board today :slight_smile:

Excuse me for any inconveniences and wish you a nice weekend! :robot:

1 Like