Holybro telemetry problem

I have problem connecting two 433 MHz Holybro telemetry modules. I tried following: replugging the modules, resetting the settings via Mission Planner, reuploading the firmware, but the modules still struggle to connect. Here is the video showing the connection process:


I would appreciate any help.

Dear all,

thanks for your topic and excuse me for our late reply.

I’ve redirected the video link to the manufacturer and hoping they can solve your issue. Otherwiese please contact us via email (https://www.mybotshop.de/Kontakt) and we will test the Telemetry set in our facility and send you a new one.

Have a nice easter weekend :robot:

Dear all,

it seems the amplifier has been broken. We will send you a replacement.

Excuse me for any inconveniences and wish you a nice weekend :slight_smile:

New modules have just arrived and everything is working fine. Again big thank you for your support.
Have a nice day.

I experienced the same problems as @fpv016. The modems just couldn’t connect.

For me it solved the problem to change the USB cable. The original Holybro USB cable worked, some other USB cable didn’t. I assume the other USB cable wasn’t able to deliver enough power to the powerful Holybro 500 mW module, as the same calbe has worked fine for a weaker 100 mW modem.

Another interesting point to know is that the power of the Holybro modems cannot be configured. They are set to maximum power from factory (500 mW). The software power parameter (i.e. 20 dBm) is ignored.

Will test the Holybro 500 mW modems on range today.

Changing the USB cable and swapping modules was the first thing I did when the problem had occurred. Before then, everything worked like it should and I didn`t have any problems with cables provided by manufacturer, so I assume that the amplifier must broke during operation.