SHOP News & Articles Contact Impressum

Go1 Edu, only zeroes and no movement with example_position

Hi!

I’m trying to get the example_position working on the robot, but only receive zeroes, let me explain.

I am connected to the robot through Ethernet, and I am following the tutorial to test the example_position. Making the package worked well. When I start the example_position, I receive only lines of 104896 0.000000 0.000000 (with the first number incrementing). This corresponds to printf("%d %f %f\n", motiontime, state.motorState[FR_1].q, state.motorState[FR_1].dq); in the cpp file. This means that my computer doesn’t receive the actual position and velocity of the joint.
I checked with Wireshark, and UDP communications are both ways from my computer to the MCU (IPs 192.168.123.10 and 192.168.12.132), and there is data in these messages, even if I cannot see what is in there I see that they are not empty and varying. I therefore suppose that there is actually the correct data sent from the robot to my computer.

What could cause the reading to give only zeroes?

For information: When I connect to the raspberry pi through Ethernet with ssh, I can start the executables from the ~unitree/sdk/unitree_legged_sdk/build directory and it works: the leg actually moves.

Thank you

Hi!

I don’t know if it’s really necessary, but did you change the robots mode to “normal mode” before running the program?
That is described in the video tutorial by Unitree on YouTube…

Does the example_walk program work for you (robot has to be in “sport mode”, which is the default it boots into)

HI!

I tried this, but no it doesn’t work…

FROM MY EXTERNAL PC:
I switched to normal mode as described and tried example_position, example_torque, example_velocity. In all cases nothing happens. The “state” variable seems to be empty in all cases.
Then I rebooted, stayed in sport mode, and tried example_walk. Still nothing happens, only lines of zeroes.

FROM THE RASPBERRY PI IN THE ROBOT:
Everything works.

Seems a little bit odd to me.

Which version of the SDK are you using?

I’m using unitree_legged_sdk 3.8.0.

In case it can help:
I’m on Ubuntu 20.04
Legged_sport version:1.32 (as shown after running sudo ./bin/Legged_sport -v )
Sport Mode version: 1.3.8 (as shown from the app)

This seems to be an issue with the type of connection. On ethernet and on wifi hotspot it behaves differently. When you run the command on which connection are you on?

Please refer to this topic .

I’m connected through ethernet, and the udp connection is using the IP address 192.168.123.10.

This definitely seems to be a connection issue then. Have you tried following the video link post by jgrube?

Also try connecting over WiFi, does exhibit the same behavior?

Yes I have followed the video, and this says to use the IP address I’m using when using ethernet. I also tried to use the one ending with 161 but it does exactly the same thing.
What is weird is that with a sniffer I can see that some data is going both ways through udp, and even if I cannot see what is in there, it’s not only zeroes. See example below of one message in hexadecimal format, from the 192.168.123.10 to 192.168.123.162.

00e04c36131a0080e10000000800450003509e3f0000ff11a25fc0a87b0ac0a87ba21f471f9a033c93b0ff1d000000000000000032c77e3f0e02b3bb62854fbabd89c73d2c7019bcf484ad3b71f3f0ba0c22c43becdfb7bd8c381b4145af34bcd00106ba6bdc473e4c00cf53febe4ac436bbfffffaff0000000000000000000031400000000000000000e6db933f4bdf1d3c0000faff000000000000000000002940000000500100000a3ad32cc06c4b1ebcfdff0900000000000000000000002b000000006301000000ade4ba3da26c27b70b000600000000000000000000002e40000000210100000accf6b13f1dec1eb911000000000000000000000000002a00000000230200000a4fe325c09d44893b0400dbff000000000000000000002d00000000260200000010d7f43ea7f5833c07000000000000000000000000002d4000000021020000007eba883fb96dc93bf8ff00000000000000000000000027400000004f0100000ab8722ac0a741d8b700001200000000000000000000002f0000000060010000007708fc3e6cc3263c07001200000000000000000000002d4000000050010000002365893fc6c92eba0000faff000000000000000000002740000000230200000a4c502bc064ff16bc0d000900000000000000000000002a000000006201000000de1008420000000000000000000000000000000000000000000000000000000048060c420000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000002000010017005c000000000000000000969016000000000000000000000000000000000000000000000000000000000000000000000000000000000003000000d616c0d20000ff0087169821e6d8ef3ff8eece5f2e5a76bfa57800a479

Unfortunately I cannot connect with wifi because my computer does not connect to 5GHz networks.

@Sohail about #7:
My problem only existed via wifi…

Ok, I found out that the problem is solved by going back to an older version of the sdk. Now I put version 3.4.2 on my external computer and it works.
@MYBOTSHOP_Support, that’s probably something that should be brought to the ears of the manufacturers.

1 Like

@Rob I’d guess the best place to address this issue is the issues section on GitHub.

Footer With Address And Phones