SHOP News & Articles Contact Impressum

Error when start High Level Mode on A1 robot

Hello !

I am currently having an issue when trying to run roslaunch qre_ros high_level_mode.launch (in su mode). It used to work but I’ve had to reinstall the workspace so I used the a1_installation_script.bash. However, it is not working. Whenever I try to start the high level mode, I get a “[node_lcm_server-2] process has died” error, making it impossible to control the robot. Do you have any idea as to what might cause this and how I could fix it ?

Thank you !

PS : this is the entire log that I get if that can help.

Also, if I try reinstalling the sdk, I get messages like this (if that can help identify the problem) :

Hi @AlaricLcrs,

It seems that the initial qre package has not been deleted. To run the a1_installation_script.bash, you may simply delete the previous qre package along with the devel, log, and build folder of your catkin workspace (i.e. manually delete it, or run catkin clean -y) and run the bash script. Alternatively, you can create a new catkin workspace and follow the instructions to run the bash script there.

Hello, thank you for your answer !

Unfortunately, yes, I have deleted the “qre” and “third_party” folders in catkin_ws/src/ but still get the same issue. Do you have any idea where it might come from ?

Have you also deleted the build devel and log folders?

Yes, I have. I’ve also deleted the “build” file in qre_a1_pkgs/utils/lcm, without success.

Please uninstall the qre installer package as well. Re-download the installer package from Quadruped A1 Robot Driver — A1 Tutorials 1.0.0 documentation and then run a clean installation.

If the issue still persists, we can arrange an online meeting.

I have re-downloaded the installer package and am getting this error when the workspace is building

I’ve sent a message to you for a meeting. Also,

"Enter workspace name: " qre_a1_pkgs
"Enter workspace path (Enter full path): " /home/unitree

the path should be outside the install script as shown.

Shouldn’t I put “catkin_ws” for “Enter workspace name” ? I’ve just tried putting “qre_a1_pkgs” but I get a lot of errors

Do note that each time that you run the install script it builds the binary libraries like LCM system wide so if before you run the script again, you must either download the qre installation package fresh from Quadruped A1 Robot Driver — A1 Tutorials 1.0.0 documentation or manually delete the build folders in the qre installation package of the lcm, aliengo_sdk, and unitree_legged_sdk.

Also in the event that you want to update your workspace, reinstall it, or change it. Directly delete the
devel, log, and build folder of your catkin workspace (or run catkin clean -y ) and run catkin_make.

For future reference: Do not run the installation script as the installation script is meant as a one time fresh installation solution. We will update the instructions on the documentation for more clarity soon.

Maybe try a1 as the ws_name or something else, the errors are coming because of the installer pkg. So please reinstall the qre installer package because if it fails then the build folders are corrupted.

Thank you for your answers ! However, I do delete everything each time but when I try reinstalling the qre installer package, I get this error

Do you have any idea how to solve it ?

What I delete before running the qre installer package :

catkin_ws/utils
catkin_ws/devel
catkin_ws/logs
catkin_ws/build
catkin_ws/src/qre
catkin_ws/src/third_party

Am I missing something ?

And do I have to use this :

Or this :

"Enter workspace name: " catkin_ws
"Enter workspace path (Enter full path): " /home/unitree

?

Thanks

A manual installation guide can be used also. Download the Quadruped A1 Robot Driver — A1 Tutorials 1.0.0 documentation but do not run the bash script.

  1. Create a your new catkin_ws and build it via
    cd
    mkdir catkin_ws
    cd catkin_ws

  2. Copy the contents of the qre_a1_pkgs into the new ws

cp -r <qre_pkg_directory>/qre_a1_pkgs/src .
cp -r <qre_pkg_directory>/qre_a1_pkgs/utils .

Now in your catkin_ws you should have src and utils folder

  1. Build util libraries

cd
cd catkin_ws
cd utils/lcm && mkdir build && cd build && cmake … && make
sudo make install

cd
cd catkin_ws
cd utils/aliengo_sdk && mkdir build && cd build && cmake … && make

cd
cd catkin_ws
cd utils/unitree_legged_sdk && mkdir build && cd build && cmake … && make

  1. Export env variables

export QRE_PATH=/home/unitree/catkin_ws
. /home/unitree/catkin_ws/utils/qre_unitree_envs.bash
echo “export QRE_PATH=/home/unitree/catkin_ws” >> ~/.bashrc
echo “. /home/unitree/catkin_ws/utils/qre_unitree_envs.bash” >> ~/.bashrc

  1. Build workspace

cd
cd catkin_ws
catkin_make
. /home/unitree/devel/setup.bash

Please tell at which step the error occurs in!

"Enter workspace name: " catkin_ws
"Enter workspace path (Enter full path): " /home/unitree

this one you can use also

"Enter workspace name: " a1
"Enter workspace path (Enter full path): " /home/unitree

It occurs during catkin_make !

Can you please post the error.

It occurs during catkin_make !

It’s the exact same as this one.

Footer With Address And Phones