SHOP News & Articles Contact Impressum

Cubemars Ak60-6 not detected by Cubemars upper program

I have plugged my R-link to motor and supplied power and trying to connect to upper program as described in this video.

Cubemars program is not detecting motor on powering on. I have also updated firmware but still same result.

But I can see the serial output of the motor on putty serial terminal with all the options of calibration and zero position set etc. Am I missing any crucial step?

I am attaching a screenshot from Cubemars and putty terminal.

Screenshot 2022-04-28 084314

Hi Zainroid, thanks for your feedback, could you please power on the motor while keep clicking the bootloader button on the Mode Switch page like picture below. Then there will be a pop-up box coming up. If so, you can click to enter MIT mode.!

Hi Joy, thanks for your quick response. I have tried your mentioned step about keep clicking bootloader button while powering on the motor but I did’t get any pop up box like before.

Zainroid. I have the same issue. Can you please share how to use the putty software to check the motor? Also, if you find any solution, please post how you did it.
Thanks
Paulo

Hi @phribeiro , I have connected the motor to PC serial port using R-Link. On Putty, open your serial port (which you may check in your device manager(windows) or ls usb command(linux) ) on putty with baudrate 921600. On powering up the motor, you will see the serial prompt on putty automatically.

I am attaching a screenshot, my serial port was COM2 .

serial

1 Like

Thanks. One question. When you turn the motor on, the led on the motor keeps blue or turns green?
Mine keeps in blue and I believe I have a malfunctioning board, I tried to connect also with an Arduino and can bus (2515) and it never turned green or connected.

Unfortunately we don’t know the LED Status

@Joy may you know the LED Status and could explain the behavior?

Hi guys, here are the LED Status of driver board instructions, and you can refer it on Page 9 on our manual.

  1. Power indicator (when blue light is on): is used to show the power supply of the driver board. Normally, it will light up blue when the power is plugged in. If the blue light is not on, please remove the power immediately and never turn on the power again.

  2. Communication Indicator (when green light is on): is used to show the communication status of the driver board. normally the driver board will light up green when the driver board communicates normally. If the green light is not on, please check whether the CAN communication wiring is normal.

  3. Drive Failure Indicator (when red light is on): is used to show the failure of the drive board. Normally, it will light up in red only when the driver board fails, and it will usually go off under normal circumstances. When the drive failure indicator lights up, it means that the driver board has been damaged. The power supply should be turned off and no operation is allowed.

Hi Zainroid, thanks for your reply, I suppose i get the situation, maybe the motor you have is AK60-6 V1.0, could you please check the laser on the bottom cover? If so, you need to use another upper computer software.

@Joy Now I am using this other upper program. RLINK Config Tool and somehow this one is also not responding. I am getting errors in both display modes and configuration modes. Can you please tell which upper program to use for this?

Thats the board I have:

I guess you need to check the USB wire from Rlink to your computer.

Footer With Address And Phones