SHOP News & Articles Contact Impressum

Connect PC to Unitree A1

I would like to connect my laptop to the Unitree A1 robot, be it via Ethernet cable or WiFi. In principle, I want to receive on my laptop all the ROS messages running on the robot.

What is the procedure to access the ROS messages on the robot?
Is there a static IP on both the Raspberry Pi?

Hi,
You can get the data from the robot either connecting with Wifi or LAN. To get the access to the robot you can attach a screen to the robot and then turn it on and check the ips. Because there are two pcs on the robot one for low level control having robot’s base software and one rasberry pi or NVIDIA.

In my case the ips my robot had was:

For the main controller PC:
ssh -X unitree@192.168.123.161

For rasberry pi:
ssh -X pi@192.168.123.12

Password: 123

I got a UnitreeRoboticsA1-417 WiFi-Router being advertised. What’s the password, though?

Note: I cannot receive any HDMI unfortunately. But that’s a different topic…

Hi Arthur,

thanks for the topic.

I can highly recommend our QUADRUPED A1 Software Guide.
QUADRUPED_A1_Software_Guide

Furthermore please feel free to visit our product page and check out the PDF and Miscellaneous section.

1 Like

@Artur You have to check for the password in the documents if its not there you can email support@mybotshop.de as I’ve never used this the reason is latency over the WLAN network might occur. So I’ve always used a direct connection for the setup and development.

For next point not getting the HDMI connection problem, as I said in the last thread there are two pcs on the robot. The front side of the robot has some ports they are for Rasberry Pi. Here you can connect the HDMI cable and than restart the robot because if the robot is turned on and than you connect an HDMI adapter it will not show anything. So you’ve to restart after HDMI connection.

I think getting connection to Rasberry Pi and its ip is enough but you can do the same procedure for the other main PC for robot communication.

Solved. Thank you :slight_smile:

Hello,

if I try to connect with ssh it says “connection refused”. What am I missing?

Hi Tim,

what does ifconfig or ip addr tell on your computer?

Thank you for your response.
The ssh worked on a colleagues PC without problems. I am using Ubuntu on a VM.

ifconfig:

enp0s5: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.211.55.9  netmask 255.255.255.0  broadcast 10.211.55.255
        inet6 fdb2:2c26:f4e4:0:ccc2:8de9:1146:eb26  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::77cd:bcbb:cc2:eeca  prefixlen 64  scopeid 0x20<link>
        inet6 fdb2:2c26:f4e4:0:6cfb:eb4c:c269:edaf  prefixlen 64  scopeid 0x0<global>
        ether 00:1c:42:42:65:b6  txqueuelen 1000  (Ethernet)
        RX packets 1561  bytes 1493005 (1.4 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1270  bytes 121698 (121.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enx8cae4cee817b: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 8c:ae:4c:ee:81:7b  txqueuelen 1000  (Ethernet)
        RX packets 20  bytes 3095 (3.0 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 112  bytes 18803 (18.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 690  bytes 70145 (70.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 690  bytes 70145 (70.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:1c:42:42:65:b6 brd ff:ff:ff:ff:ff:ff
    inet 10.211.55.9/24 brd 10.211.55.255 scope global dynamic noprefixroute enp0s5
       valid_lft 1263sec preferred_lft 1263sec
    inet6 fdb2:2c26:f4e4:0:ccc2:8de9:1146:eb26/64 scope global temporary dynamic 
       valid_lft 603545sec preferred_lft 84875sec
    inet6 fdb2:2c26:f4e4:0:6cfb:eb4c:c269:edaf/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 2591832sec preferred_lft 604632sec
    inet6 fe80::77cd:bcbb:cc2:eeca/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: enx8cae4cee817b: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 8c:ae:4c:ee:81:7b brd ff:ff:ff:ff:ff:ff

Thank you for any help.

Are you using LAN for something different usually? Its IP is 10.211.55.9. The robot is in the 192.168.123.0 network. You would need to reconfigure the network device enp0s5.

You can also try to connect to the UnitreeA1-xyz WiFi. The password is 00000000 (8 zeroes). The WiFi should get an IP in the proper network and you should be able to ping the robot.

I haven’t used LAN on my laptop. Only now for the A1 now.

Do you mean the reconfiguration of the network device, that instead of the 10.211.55.9 it should be replaced by the 192.168.123.0?

Thanks a lot!

Aye, your network device should get an IP in the 192.168.123.0/24 network. In my case, upon connecting the robot to the computer, the robot gives a proper IP to my computer.

Does it work with WiFi? Is more comfortable imho when you move around the robot.

I can connect to wifi, but nfortunately it doesn’t work either. Maybe some security configuration which prevents me from connecting?

Will try to reconfigure enp0s5 for LAN too.

UPDATE: LAN works. thanks for the hint.

But Wifi still refuses connection. Is it possible for ssh via wifi that a different IP address is needed?

Footer With Address And Phones