SHOP News & Articles Contact Impressum

Access A1 robot's desktop on remote PC via wireless

Hello !

I’m currently working on an A1 robot and would like him to navigate autonomously (only with the RealSense camera, not with the additional LiDAR). I’ve managed to access the camera stream and have found an already existing GitHub that has created autonomous navigation only with the RealSense 435i (same one as the robot) but on a different robot.
Anyways, my current problem is that I would like to access the robot’s desktop on a remote PC. I already can connect to it via ssh but I would like to be able to see the feedback realsense-viewer app and other apps on my remote PC (MacOS if possible, but I can also work with Windows or an Ubuntu VM if necessary). Is that something that’s possible with the A1 robot ? Because I’ve already looked for solutions but didn’t succeed using VNC servers or other stuff that I’ve found on the Internet.

Thank you !

Great to hear you were able to find something working.

About getting a remote connection I’ve never tried with VNC or something similar. Because managing ROS data is task in itself. But usually for debugging purposes or having a control on the robot, I usually setup a wifi network and login to the robot on that. Though fps are usually less but still to have control is enough for my purpose. If you want to have something with a preconfigured server for remote visualization and control. We can guide you for a remote setup which is a real working commercial solution with custom configurations for remote setup. If you think that will be relevant please contact support@mybotshop.de

1 Like

Okay thanks ! Well the goal was mainly to get feedback from the robot, like the camera stream, on the remote PC. Because it’s not very practical to have the robot plugged to a screen when you want him to navigate. I’ll look further into it thanks !

I also have another unrelated question but I don’t know if you’re the right person to ask. It’s about the Unitree Robotics app, it used to work (I could get the camera stream on my phone) but it appears there’s been an update since then and now I can’t connect the app to the robot. Normally I would just have to connect the robot the robot’s wifi and in Setting do Enable Customization and set every ip address to 192.168.123.12 but it doesn’t work anymore. So if you have any idea or know anything about it I’d be very glad to hear it ! I’ve tried contacting Unitree directly but I haven’t had any answer so far.

Thank you for your work !

Hi Alaric,

are you using an Android or iOS phone? Where you have downloaded the app, from the Unitree website: Unitree App ?

Hi ! I’m on iphone so iOS and yes I’ve downloaded the app from their website directly, using TestFlights

Can you check the driver or the realsense connection if its there by SSH?

Well I can’t right now since the nvidia board isn’t working anymore (cf : Problem with NVidia board of A1 robot - #3 by AlaricLcrs), but realsense-viewer was working before the nvidia board stopped working. I managed to access the camera stream on the computer so I don’t think that the problem comes from there, especially since the app used to work before.

Footer With Address And Phones