Constant problem with sabertooh 2x32

Hi everybody! I’m building a crawaler with sabertooth 2x32 using two wheelchair motor with electromagnetic brake and a RC transmitter.
The first time that i connected the sabertooth to the robot, it immediately showed problems in managing the electromagnetic brakes in channels P1 and P2; the connections I made are correct in line with the instructions provided in the box.
I thought that was only a setup problem in DEScribe software, so i’ve studied the program and also asked for help to other people that already build similar robot with the same sabertooth 2x32, but nothing… my friend’s robot work very well, but my robot still don’t work… it activate the electromagnetic brake every time that I supply power to the motor making impossible to run the robot; it cannot be a problem with too much current absorption beacuse also if the robot is on plain with no load on it, it activate the brake… also monitoring the current absorption with diagnostic, it show low current absorbtion.
Now, every time the sabertooth is powered, the error LED is always shown, nothing works and nothing moves, also resetting the sabertooth from the DEScribe software, the error message is always shown. Please help me beacause i can’t move the motor…
I would like to send the sabertooth under warranty but the site told me to post this problem on this forum…
Thanks to everyone!

Dear all,

thanks for creating a topic, we will do our best to support you as good as possible.

Do you’ve checked the Sabertooth Basic Troubleshooting?

Wish you a nice evening :robot:

The Sabertooth has taken firmware and/or hardware damage. Please contact the manufacturer, Dimension Engineering for further support:

i have already contacted the manufacturer, but they don’t solve this problem…
Now the error status led is always showed and nothing move, i have also a video that show this but i cannot attach in this post

Hi, thank for the support, but the basic troubleshooting for led status don’t solve my problem…

Dear all,

could you please tell us your ticket no. or just tell us when you’ve tried to contact Dimension Engineering directly so we can send them a kind reminder?

Furthermore please feel free to upload the video - The forum don’t have any max. limit

Sure, the ticket number was 9027; kindly note that you will found on this ticket another name (Paolo) because he’s building this robot with me.
Also note that on august (when we wrote the ticket to Dimension Engineering) the problem to the sabertooth was only related to the brake… now the problem is that the errur status LED is always ON, so i cannot move nothing…
I think that sabertooth 2x32 was already compromised when i bought it because it never worked well.
Thanks for the support!
PS here the link of the video on my google drive with the error status LED

Thanks for your telling the Ticket no and adding the video - You have a impressive robot! :slight_smile:

@DESupport Could you please check the ticket 9027 and assist the customer?


This the video that i made on august 2020, i should have attacched it on the tiket no. 9027, but the dimension of the file is too big so i cannot attacched.
As you can see in this video the sbertooth cannot manage well the brake, so the sabertooth never worked well.
I push for the warranty (because the sabertoot is still in warranty), because i have this robot stopped due to this problem for a lot of time and i wouldn’t want to waste more time

We have no record of “fscrawler” contacting us at Dimension Engineering Support. As mentioned above, The Sabertooth appears to have taken firmware and/or hardware damage. Go to our Contact page to access our Help Desk and/or Support email so that we can resolve this issue for you.

I know, i’ve said that before; on the tiket you will find another name (Paolo Di Renzo), because me and my friend are working on this robot.
I have spoke with Charlene
The ticket number is 9027.
I have already contacted you but you have not solve this issue.
Me too I think that the sabertooth has received firmware or hardware damage, so I would like to proceed with the warranty.

Based on the information you provided, your initial problem was due to lack of available battery power for your system. We diagnosed this on your Help Desk ticket. We understand you were resistant to this answer, but as the designer and manufacturer of the board, we are well versed in its operation. As we mentioned on your ticket, the solution is to limit motor current draw to work with your existing batteries (assuming they are still good, as you said that one was used and not an identical match), or get bigger batteries. Since the board has subsequently taken damage, we have responded on your Help Desk ticket with warranty repair information. Please go to your ticket for details.